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Kb-Sync
Collaborator III

Applies To


Product(s): Archer
Version(s): All Versions
Primary Deployment: On Premises/AWS Hosted/AWS SaaS

Description


The below error is thrown in the UI when users attempt to login to Archer using Single Sign-On with Azure (as the Identity Provider) via a Microsoft MyApps Tile.
An unexpected error has occurred in the system. The error Log Reference ID is: xxxxxx-xxxxxx-xxxx. Please try your request again. If problems persist, please contact your system administrator.

0EMVM00000BVw4c.png0EMVM00000BVw4c.png

Also, the above error replaces the user's Default Home Page and would allow the user to interact with Archer as expected after a page refresh. However, Archer may be prevented from loading entirely if the user has an existing tab or active session token.

 

Note: The Microsoft MyApps Tiles enable users to access Archer directly, bypassing the Logon Decision page. When a user clicks on the MyApps tile set up for Archer, they are taken straight to the platform without needing to choose a login method.


Cause


The Sign-on URL in the Azure application is not configured correctly.


Resolution


To access Archer using Single Sign-On via a Microsoft MyApps Tile, ensure that the Sign-on URL in the Azure application is populated correctly.

Follow the steps below:

1. Login to Azure and open the configured application for SSO.

2. From the left pane, expand Manage and click on Single sign-on.

3. From the middle pane, select SAML under Select a single sign-on method.

0EMVM00000BVTlo.png0EMVM00000BVTlo.png

4. In the Set up Single Sign-On with SAML page, go to the Basic SAML Configuration window and click on Edit.

5. In the window that appears, populate the Sign on URL with the below format.

[BaseURL]/Default.aspx?IDP=<Insert the Realm value here>

0EMVM00000BVisr.png0EMVM00000BVisr.png

Note: 

      • 'Archer1' in the above screenshot/example is the Realm.
      • The Realm is found under the Instance settings in the Archer Control Panel. The steps to retrieve it are described below.

6. Then click on Save.

 

Follow the steps below to retrieve the value of the Realm:

1. Logon to an Archer Server and open the Archer Control Panel.

2. Double-click on the Instance name in the left pane to open the Instance settings.

3. Go to the Single Sign-On tab.

4. Locate the Realm field below the Identity Providers section.

5. Retrieve the value in the Realm field and insert it in the Sign-On URL as stated above.

0EMVM00000BbgGT.png0EMVM00000BbgGT.png

Note: Hosted/SaaS clients would need to raise a support case to obtain the Realm value.

 

After retrieving the Realm value and updating the Sign-on URL in Azure with it as described above, the Microsoft MyApps tiles should begin authenticating users successfully as expected.


Version history
Last update:
‎2024-11-18 09:29 AM
Updated by: