Important Update: Archer Community Scheduled Maintenance on November 23–24 - New Community Launching Soon! Learn More..

cancel
Showing results for 
Search instead for 
Did you mean: 
No ratings
Kb-Sync
Collaborator III

Applies To


Product(s): Archer, Engage
Version(s): All Versions
Primary Deployment: On Premises/AWS Hosted/AWS SaaS

Description


When saving an Engage record after it got published successfully to Engage, the below error is thrown.
An unexpected error has occurred in the system. The error Log Reference ID is: xxxxxx-xxxxxx-xxxx. Please try your request again. If problems persist, please contact your system administrator.
0EMVM00000BP9o9.png0EMVM00000BP9o9.png

The expected behavior is that the Conflict Resolution page (shown below) would appear after saving due to that the Engage Status field value has changed but is still not reflected in the record page.

However, this does not occur and the above error is thrown instead.

0EMVM00000BTCIn.png0EMVM00000BTCIn.png 

The below errors (related to the Log Reference ID) are found in the w3wp logs:

<E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEvent">
<System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system">
<EventID>0</EventID>
<Type>3</Type>
<SubType Name="Error">0</SubType>
<Level>2</Level>
<TimeCreated SystemTime="2024-08-29T19:53:57.9880115Z" />
<Source Name="Archer.Web" />
<Correlation ActivityID="{00000000-0000-0000-0000-000000000000}" />
<Execution ProcessName="w3wp" ProcessID="7388" ThreadID="5" />
<AssemblyVersion>6.15.200.10416</AssemblyVersion>
<Channel />
<Computer>Server Name</Computer>
</System>
<ApplicationData>
<TraceData>
<DataItem>
<TraceRecord Severity="Error" xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord">
<TraceIdentifier>Archer.Web</TraceIdentifier>
<LogReferenceId>xxxxxx-xxxxxx-xxxx</LogReferenceId>
<Description>Object reference not set to an instance of an object.</Description>
<AppDomain>/LM/W3SVC/1/ROOT/Archer-1-133694338995134985</AppDomain>
<ContextData>
<BaseUrl><https://Server Name/Archer/GenericContent/Record.aspx</BaseUrl>>
<id>0</id>
<Module>ModuleId: 616, ModuleName: Information Security Assessment, ModuleStatus: ActiveInProduction, ModuleType: Questionnaire</Module>
<rr>db105e35fe8d478e9e4e3056f7958a27</rr>
</ContextData>
<Exception>
<ExceptionType>System.NullReferenceException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</ExceptionType>
<Message>Object reference not set to an instance of an object.</Message>
<Source>ArcherTech.Web.Modules.GenericContent</Source>
<StackTrace> at ArcherTech.Web.Modules.GenericContent.Views.RecordPresenter.ValidateFieldIdValue(Nullable`1 fieldId)
at ArcherTech.Web.Modules.GenericContent.Views.RecordPresenter.ValidateEngageFieldsBasedOnConsumerType()
at Security2000.GenericContent.Record.EnablePublishButton()
at Security2000.GenericContent.Record.InitWorkflowButtons(WorkflowJobData workflowJobData, WorkflowConfiguration workflowConfiguration, Boolean isEditMode, Boolean isViewMode)
at Security2000.GenericContent.Record.OnPreRender(EventArgs e)
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)</StackTrace>
</Exception>
</TraceRecord>
</DataItem>
</TraceData>
</ApplicationData>
</E2ETraceEvent>

Cause


One or more of the fields required for publishing an Engage record are removed from the Default Layout.


Resolution


Ensure that all fields required for publishing an Engage record are added to the Default Layout.

Follow the steps below:

1. Login to Archer as an administrator.

2. Expand Administration menu > Expand Application Builder > Select Applications > Open the affected Engage module.

3. Go to the Designer tab > Layout sub-tab.

4. Under the Data Fields pane, locate the fields (required for publishing a record to Engage) which are off the Default Layout

5. Drag and drop these fields onto the Layout Builder in the middle pane. Ensure that Default Layout is selected under the Layouts dropdown in the top-left of the page.

0EMVM00000BTBD6.png0EMVM00000BTBD6.png

6. Then click on Save Layout.

 

Note: The required fields for publishing a record to Engage can be found via either of the below methods:

  • Below the Engage tab in the Application Builder page of the module.

0EMVM00000BStXu.png0EMVM00000BStXu.png

  • In the Portal Button Custom Object code (Open the Application Builder page of the module > Designer tab > Layout sub-tab > Layout Objects pane > Locate and click on the Portal Button Custom Object > Expand its Properties > Locate the required fields in the Code under Custom Object Properties (as shown below)).

0EMVM00000BSz8f.png0EMVM00000BSz8f.png


Version history
Last update:
‎2024-11-18 06:29 PM
Updated by: