Important Update: Archer Community Scheduled Maintenance on November 23–24 - New Community Launching Soon! Learn More..

cancel
Showing results for 
Search instead for 
Did you mean: 
No ratings
KB-Sync1
Archer Employee
Archer Employee

Article Number

000017350


Applies To


Product(s): Archer
Version(s): 6.x
Primary Deployment: On Premises/AWS Hosted/AWS SaaS

Description


Unable to generate a package.

Error Logs:
   
<ApplicationData>
        <TraceData>
            <DataItem>
                <TraceRecord Severity="Error" xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord">
                    <TraceIdentifier>Archer.Packaging</TraceIdentifier>
                    <UserId>70839</UserId>
                    <Description>Unable to open a Repository File for this Mail Merge Template, either because it doesn't exist, or it is locked by another process. Please make sure this file exists in your configured Repository Files directory, or remove and re-add the Attachment for this Mail Merge Template.</Description>
                    <AppDomain>ArcherTech.JobFramework.Job.exe</AppDomain>
                    <Exception>
                        <ExceptionType>System.InvalidOperationException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</ExceptionType>
                        <Message>Unable to open a Repository File for this Mail Merge Template, either because it doesn't exist, or it is locked by another process. Please make sure this file exists in your configured Repository Files directory, or remove and re-add the Attachment for this Mail Merge Template.</Message>
                        <Source>ArcherTech.Packaging</Source>
                        <ContextData>
                            <FileRepositoryId>15955</FileRepositoryId>
                            <FileRepositoryName>15955.dotx</FileRepositoryName>
                            <AttachmentName>Exec_Summary_07_25_12.dotx</AttachmentName>
                            <MailMergeTemplate>Contract Executive Summary</MailMergeTemplate>
                        </ContextData>
                        <StackTrace>   at ArcherTech.Packaging.Actions.Generation.GeneratePackage.ThrowMailMergeTemplateRepositoryFileException(SessionContext sessionContext, Guid mailMergeTemplateGuid, RepositoryFile file, Exception innerException)
   at ArcherTech.Packaging.Actions.Generation.GeneratePackage.&lt;AddRepositoryFiles&gt;b__193(GenerateContext context, ExecuteActions`1 ignored)</StackTrace>
                    </Exception>
                </TraceRecord>
            </DataItem>
        </TraceData>
    </ApplicationData>
</E2ETraceEvent>

 

Cause


Packaging cannot complete, if a mail merge template associated with that application is not available.

Resolution


Option 1: Find the Mail merge template:
  1. Go to Administration -> Management Reporting -> Manage Mail Merge Templates -> Look for the relevant Mail Merge Template that is mentioned in the logs.
  2. Open the template -> At the bottom you should be able to see the template. Click on it and save a copy.
  3. Delete this template and then re attach it with the one you just saved. Save the template and try generating the package again.

Option 2: If you do not need these mail merge template, then you can just delete it by going to Management Reporting -> Manage mail merge template -> Look for the template name as mentioned in the logs -> Delete. And try generating the package again.

Version history
Last update:
‎2024-09-21 06:51 AM
Updated by: