Important Update: Archer Community Scheduled Maintenance on November 23–24 - New Community Launching Soon! Learn More..

cancel
Showing results for 
Search instead for 
Did you mean: 
100% helpful (3/3)
Nashwa_ElKholy
Archer Employee
Archer Employee

Applies To


Product(s): Archer

Description


Images and Logos appear to be broken or missing in the UI as shown below.
0EMVM000001j37e.png0EMVM000001j37e.png
The following has been confirmed:
  • The affected images/logos are present in the company_files folder.
  • In case a Service Account is used (whether for Single Host or Multi Host environments):
    • The Application Pool Identity in IIS is running using the Service Account.
    • The Service Account has full access to the company_files path.
    • The company_files path is shared, in case of Multi Host environments.

Cause


There is a web.config file in the company_files folder. To confirm that this is the cause, follow the steps below:
1. Open IIS and go to the website where RSA Archer is installed (i.e., Default Website or RSAarcher, depending on your setup).
2. Expand the website and click on the company_files folder below it.
3. Then double-click on Authentication from the middle pane.
4. The below error will appear.
0EMVM000001jEKn.png0EMVM000001jEKn.png
5. Then right-click on company_files from the left pane and click on Explore (as shown below).
0EMVM000001iwW1.png0EMVM000001iwW1.png
6. This will direct you to the company_files folder where a web.config file will be found as shown below.
0EMVM000001jEcX.png0EMVM000001jEcX.png
 

Resolution


Remove the web.config file from the company_files folder. Then login back to Archer, the images/logos should now appear normally.
Note: The above checks and steps should be followed and performed on all Web Servers.
 

Version history
Last update:
‎2024-09-21 05:54 AM
Updated by: