Important Update: Archer Community Scheduled Maintenance on November 23–24 - New Community Launching Soon! Learn More..

cancel
Showing results for 
Search instead for 
Did you mean: 
No ratings
KB-Sync1
Archer Employee
Archer Employee

Article Number

000034984


Applies To


Product(s): Archer
Version(s): All Versions
Primary Deployment: On Premises

Description


  • The Archer user interface indicates that a package installation is running.  However, the job is no longer running in the job engine. 
  • A new package installation for this package cannot be started while the existing one is stuck in a running state.

Cause


The job may have failed or may have been intentionally removed.

Resolution


  1. Replace the highlighted area (e.g. INSERT PACKAGE NAME) and insert the package name. Run the first query to display the status of the package installation

/*	** DISPLAY STATUS OF PACKAGE INSTALLATION **
	
	** LIST JOB STATUS CODES ** 	
SELECT * FROM tblJobStatusDef 

*/  ** DISPLAY STATUS OF PACKAGE INSTALLATION **
SELECT 
p.package_name,
pr.job_id,pr.package_id,pr.run_id,
js.job_status_id,jsd.job_status_name
FROM tblPackage p 
JOIN tblPackageRun pr on pr.package_id=p.package_id
JOIN tblJobStatus js on js.job_id=pr.job_id
JOIN tblJobStatusDef jsd on jsd.job_status_id=js.job_status_id
WHERE p.package_name = 'INSERT PACKAGE NAME'
 
  1. Replace the Job ID found from the first query and replace into the high-lighted area (e.g. INSERT JOB ID)

/*	** TO SET JOB STATUS TO 4=FAILED: ** */
UPDATE tblJobStatus 
SET job_status_id='4'
WHERE job_id = 'INSERT JOB ID'

Version history
Last update:
‎2024-09-21 07:38 AM
Updated by: