Article Number
000038201
Applies To
Product(s): ArcherVersion(s): All VersionsPrimary Deployment: On Premises
Description
Jobs are stuck in the Job Engine Manager. They should have run but didn't. The Enqueued Date and Inactive Until date are both in the past.
Cause
- A SQL Backup is performed on an Archer environment's Instance database while Archer Jobs are running and the backup is restored to another environment. e.g., copying a QA instance database backup and restoring over the Test instance database.
- When the target environment is restored, the running jobs do not exist and there is nothing to update or remove the jobs from the database.
Resolution
Stop and prevent new jobs from running on each Archer Services server.
- In the Archer Control Panel under the Plugins, Job Engine Manager.
- Under the Servers tab, enable/check the Discontinue Job Processing option.
- Click Update button.
- Wait for running jobs to finish (that are working).
- If the jobs are taking too long and Admin doesn't want to wait, the job's processes can be killed using Task Manager.
- From each Archer server running the Job Engine service, open Windows Task Manager and select the Details tab.
- Right-click the ArcherTech.JobFramework.Host.exe process and select End process tree.
- Uncheck the Discontinue Job Processing option
- Click Update button.
- Restart Archer Job Engine service.