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KB-Sync1
Archer Employee
Archer Employee

Article Number

000033417


Applies To


Product(s): Archer
Version(s): All Versions
Primary Deployment: On Premises

Description


After upgrade, the Archer Control Panel (ACP) can be opened, but the Instance is missing.

Cause


The wrong connection string in the ArcherTech.Services.ConfigurationService.exe.config file is pointing to the Instance database instead of the configuration database.

Resolution


Change the connection string in ArcherTech.Services.ConfigurationService.exe.config to point to the configuration database instead of the instance database and restart the Archer services.
  1. On each Archer Web and/or Archer Services server, open the ArcherTech.Services.ConfigurationService.exe.config file for edit.  (Typically installed in C:\Program Files\(Archer Installation Folder)\Services)
  2. Find the <connectionStrings> node in the configuration file and validate/change this connection string (according to your scenario). 
  3. Save the changes to the ArcherTech.Services.ConfigurationService.exe.config file. 
  4. Restart the Archer Services

For example, change:
add name="SqlDB" connectionString="Server=myoldserver;Database=myoldconfigurationdatabase;UID=myolduid;PWD=myoldpwd;" providerName="System.Data.SqlClient" />
To this:
<add name="SqlDB" connectionString="Server=myNewServer;Database=myNewConfigurationDatabase;UID=myewuid;PWD=mynewpwd;" providerName="System.Data.SqlClient" />

Windows Integrated connection string example:
<add name="SqlDB" connectionString="Server=myNewServer;Database=myNewConfigurationDatabase;Integrated Security=SSPI;" providerName="System.Data.SqlClient" />

Version history
Last update:
‎2024-09-21 07:45 AM
Updated by: